Give Your Beta Robot A New Lease of Life!


#1

Hi Guys!

As you may have noticed (from your own play or from Benerator’s post), beta robots can’t handle the latest firmware update and will begin to lose functionality now. However, there is a cure! If you would like to keep your beta robot up and running, the lovely hardware guys have compiled a guide for you to follow so that you can manually update your robot’s firmware yourself.

Step 1: Download nRF Toolbox App

Download Nordic’s “nRF Toolbox” app onto any device that can access email and connect to your MekaMon.

Step 2: Download and Email The Firmware Update File

The Firmware Update file can be found below. Download the file as a .zip and then email the file to an email address you can access on your device.

MekamonDFUAppV007.zip (19.9 KB)

Step 3: Load Firmware Update File To App

You will need to load the Firmware Update file into the file selection part of the nRF Toolbox App before you can upload it to the robot.

Go to the “DFU” Section of the App

Press “Select File” and then User Files at the bottom of the screen that appears.

Follow the instructions in the ‘How To’ section to upload the firmware file. You will need to select the ‘Add Files from Email’ tutorial.

The ‘Firmware Update’ menu should now look like this:

Head back to the Main Menu and click on the UART icon.

Click on the edit button, the squares above will turn red. Select one of them.

In the text box, add 10 capital A’s (“AAAAAAAAAA”) and select an icon. Press “OK” when you are finished.

Step 3: Update Process

Now it is time to update the robot. Stay in the Default UART screen and click the “CONNECT” button at the bottom of the page.

This will bring up a menu of devices. Your MekaMon will appear as either “Meka_[last 8 characters of your serial number]” or “MekaMon”. Note that you can check your serial number by removing the battery and checking the larger number beneath the barcode inside the body of the robot.

Once connected, press your newly created button in the Default UART screen. You will only have around 30 seconds from pressing this icon to complete the rest of the tutorial successfully, so perhaps read ahead now so that you can get the gist of what you will be doing as you follow.

It will appear that the App has not done anything when you press this button, however behind the scenes the App has put the robot’s bluetooth module into reset mode and it will disconnect from your MekaMon. You can check that the process has been successful by seeing if your robot has disconnected, or by checking the logs.

Now, go back to the Main Menu and click on “DFU” again.

Press “Select File” and then “User Files” again. This time, you will see an “Inbox” option. This is where the Firmware Update file you uploaded to the App has been placed.

Open “Inbox”, select the Firmware Update file and press “Done”.

Once the file has been loaded in the DFU screen, click “Select Device”.

Your MekaMon will now appear as “Dfutarg” in the menu that appears. Select it and press Connect.

Once the App is connected to “Dfutarg”, and your file is in the “FIRMWARE” box, click “Upload”.

Once the upload reaches 100% completion, the bluetooth module on your robot will reset. At this point you will need to reset the robot. After this reset, your robot will work with the new firmware.

If you find that you have failed this stage, you may have left too much time between pressing the “AAAAAAAAAA” icon you created to pressing the “Upload” button - there is only around 30 seconds available for you to do this in. If it does time out in this way, simply go back and press the button you created once more and proceed from there.

As always, if there’s anything we can do to help - or if you have any questions, give us a shout at support@reachrobotics.com!


#2

#3

I followed the boot operation, but found that the app could not find the robot, what should I do?


#4

Hey there! At which stage does your device lose sight of the MekaMon?


#5

After the upgrade is complete, I can’t search for Bluetooth in the latest app.


#6

Hey Kimjin,

Just a couple of question,

You have a beta robot?
It received the V2 software from the app which caused it to stop working?
You followed the instructions above and it has now disappeared on the app?
Is the robot still visible on the light blue app mentioned in the instructions above?


#7

Yes, I have a beta version of the bot that can connect to the Bluetooth list when using the app, but it cannot be upgraded and cannot be used.
I can’t search in the app after I follow the boot upgrade.
I can search for it in the blue app, called MEKAMON, but I can’t search it in the app.


#8

Had your robot updated via the mekamon app to V2 first?

Chris


#9

No, then what should I do now?


#10

We are trying to work out a solution now. We expected the mekamon app update first to the robot which causes the break which the above fix solves. Doing the fix early gives us some problems, give me a few hours to find a solution.


#11

How you ever updated the robot using the mekamon app?


#12

I can use the testflight version of the app to control it. After the app was upgraded, I have been unable to upgrade the firmware until I saw this post and tried the above method.


#13

So the Robot has never updated via the mekamon app?

~Sorry for the delay.
We think we know the problem but we are trying to work out a more user friendly way to solve the problem.


#14

Yes,Looking forward to your solution


#15

Hi.

I did the whole procedure and everything seems to have gone as predicted, but when I connect the meka with the app it still says I need to upgrade the firmware.

Perhaps the last step was not done properly: how do you reset the meka? I just plugged the battery out and back in.

Thanks.


#16

Hey @kimjin, @docjaq is following up with a custom build to solve this issue. I’ll let him take over here.

Hey @ulaikamor, What happens once the robot tries to update again? The above BLE update is separate from any normal MekaMon Firmware so there might still be a robot update waiting.


#17

Yep. You should have a DM from me to deal with the issue you’re having.


#18

Hey @Chris_CTO.

When the meka is back up, it says it requires a Firmware update. I try to update, but there’s no progress.

It’s trying to update from 1.15 to 2.01.

Thanks.


#19

Hey @Chris_CTO @Tabs ,

Since my last reply, I tried one last time to perform the update and was able to do it successfully. :slight_smile:

What I hadn’t realized is you actually need to be close to the meka with the tablet for the transfer to take place. Being 2-3m away from the meka does make a difference for the Bluetooth connection.

Thanks.


#20

Ahhh yeah, the update process sends alot of data compared to the normal BLE traffic for gameplay.

Glad its all worked out now.